Galaxy City
    avatar

    玩 Minecraft,也是有讲究的!(?

    自从我把重心从 PVP 圈子挪开、将一部分重心挪到生存圈之后,为了方便,我就拿着我的 Lunar Client,同时用 1.8.9 和 1.18.2 版本。但是,我有点没想到的是,他的通病还是有的(恼)。

    这是为什么

    因为方便(是懒吧),我玩生存的时候使用了 Lunar Client 1.18.2 版本游玩。但是,由于 Lunar Client 本身没有做版本隔离(Feather Client 也是如此),导致两个版本的设置会进行同步。就比如:我在 1.18.2 没有任何的材质包,设置也是保持默认,那么回到 1.8.9 的话,就跟以上提到的 1.18.2 的设置保持同步。我还得重新设置一次材质包,干!

    解决方案

    解决方案也不是没有,就是没法偷懒了(摊手)。

    专用 1.8.9 PVP 客户端

    上述提到,这些 PVP 客户端没有做版本隔离,导致多个版本的设置会同步,所以最好还是保持需要用到的版本。

    那么我是保留了 Feather Client 的 Forge 1.8.9 版本来游玩 Hypixel 服务器。之所以会使用 Feather,一是它可以添加自己的 Mod,比如我添加了一个 InputFix 2.0 来进行中文输入;二是它和 Lunar 功能相差不大,Lunar 有的功能 Feather 基本也有;三是稳定度也有所提升,在我使用的这段时间里,Feather 也很少有崩溃的行为发生,可能是我换了一台比较好的电脑了吧。

    FeatherUI.png

    其他版本客户端

    因为不确定哪天有活动需要用到哪个版本,而继续使用 Lunar Feather 这样的客户端是不现实的。那么一个很好的解决方法就是:第三方启动器 + 自配客户端。

    启动器

    启动器我用过 HMCL、BakaXL 和 PCL 2。经过深思考虑后我选择了 BakaXL。

    BakaXL 是我认为目前最符合我心意的第三方启动器:可以个性化、对 LittleSkin 兼容度好、有着丰富资源的笨蛋广场,等等。而且 Minecraft 档案切换不麻烦,我只要点一下开始游戏,就可以选择用正版登录还是 authlib-injector 登录,而不用在开始游戏之前提前设定好档案。

    BakaUI.png

    1.18.2 生存客户端

    我正在使用 1.18.2 游玩 YinwuRealm 生存服务器,并且还就只玩这一个服务器。

    之前一直在用 1.18.2 Vanilla + Optifine 的组合端游玩,但在一些操作上还不是非常的理想,所以我打算自己配一个 Fabric 1.18.2 客户端,并具备小地图、强制疾跑这些我游玩生存服务器需要用到的功能。

    但没想到的是,第一次配 Fabric 端居然翻车了,单人游戏正常,但一连接服务器直接自动关闭游戏。在群里面问了一下,有位热心老哥告诉我可能是 Sprint O' Meter(强制疾跑) 这个 Mod 引起的。第二天,我找了一个替代品(Toggle Toggle)替换了它,服务器也能正常进去了。太好了!

    既然端可以正常运行了,我就可以无脑加 Mod 了。我找了一个国内的 Mod 百科,然后把我可能用到的 Mod 都加了上去,最后的列表是这样的:

    1.18.2ModList.png

    顺便放一张界面图:

    1.18.2Screen.png

    目前遇到的一个问题是:不论是单机还是多人,开启游戏后第一次进入游戏,客户端会无法加载地图。单人就直接 GG,多人可以点取消重新进入。目前这个 1.18.2 客户端暂时没有开单人的需求,所以这个存在的问题应该没什么大阻碍。

    其它版本

    目前还搞了 1.8.9 和 1.12.2 的 Forge 端,但因为 Mod 还不够完善,所以就不在这里提了。